Hello and welcome to

User Tag List

Results 1 to 8 of 8

Thread: Central locking not working.

      
  1. #1
    Fresh Meat
    Join Date
    Jul 2017
    Ride
    BMW E60 545i
    Location
    UAE
    Posts
    6
    Status
    Offline
    Thanks (Received)
    1
    Likes (Received)
    0
    Dislikes (Received)
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Rep Power
    0

    Default Central locking not working.

    Hi guys,

    i have problems which appeared out of no where;


    1- my car (BMW e60 2005,545i) key stopped working, meaning i can't lock and unlock the car using the key. i have replaced the batteries and got them checked they (keys) are working fine on the testing system.The dash central locking button,locks/unlock all the doors and its working in normal manner. the strange part here is that when i use my key to manually lock the door it only locks the driver side door all the other doors remains unlocked, so when i need to lock the car, i sit inside the car, locks all the doors using the central locking button, open the driver side door only (it does not unlock other doors), get off the car and lock the door using the car key, this way all the doors remain locked. when i need to unlock, i use my key in the driver side it and it unlocks all the doors.

    2- fuel door actuator is not locking/unlocking, i checked the fuses they were fine (no blown fuse) so i ordered the new fuel door actuator motor and got replaced and the problem remains same.


    guys any idea what could be the problem?

  2. #2

    Bruno's Avatar
    Join Date
    Apr 2008
    Ride
    E30 M3, E21 320i
    Location
    DXB
    Posts
    8,248
    Status
    Offline
    Thanks (Received)
    33
    Likes (Received)
    104
    Dislikes (Received)
    0
    Mentioned
    35 Post(s)
    Tagged
    0 Thread(s)
    Rep Power
    25

    Default

    I bought a car a few weeks ago and while going through the records, the previous owner had changed the lock actuator. I asked him why did he change it, and he said they changed it to see if it would fix the locking problem that seems similar to what you described.

    The problem turned out to be from a short in the cigarette lighter socket that went nuts from a phone charger going bust.

    Not saying you could have the exact same problem. Worth sharing maybe your problem is somehow related.

  3. #3
    Fresh Meat
    Join Date
    Jul 2017
    Ride
    BMW E60 545i
    Location
    UAE
    Posts
    6
    Status
    Offline
    Thanks (Received)
    1
    Likes (Received)
    0
    Dislikes (Received)
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Rep Power
    0

    Default

    Quote Originally Posted by Bruno View Post
    I bought a car a few weeks ago and while going through the records, the previous owner had changed the lock actuator. I asked him why did he change it, and he said they changed it to see if it would fix the locking problem that seems similar to what you described.

    The problem turned out to be from a short in the cigarette lighter socket that went nuts from a phone charger going bust.

    Not saying you could have the exact same problem. Worth sharing maybe your problem is somehow related.

    Hi,

    thank you for information i will check that too.

  4. #4

    Wazif's Avatar
    Join Date
    May 2008
    Ride
    BMW E46 M3 BMW E92 M3 BMW F80 M3
    Location
    Dubai, UAE
    Posts
    4,821
    Status
    Offline
    Thanks (Received)
    111
    Likes (Received)
    262
    Dislikes (Received)
    1
    Mentioned
    55 Post(s)
    Tagged
    0 Thread(s)
    Rep Power
    25

    Default

    Ive faced a similar issue just before my car battery went completely flat! When was the last time the car battery was replaced?

    Current
    E92 M3 - Mineral White
    F80 M3 - SilverStone
    Past
    E36 318is
    E39 540i ///M sport
    VW CC
    E46 M3 - Frozen White

  5. #5
    Fresh Meat
    Join Date
    Jul 2017
    Ride
    BMW E60 545i
    Location
    UAE
    Posts
    6
    Status
    Offline
    Thanks (Received)
    1
    Likes (Received)
    0
    Dislikes (Received)
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Rep Power
    0

    Default

    Quote Originally Posted by Wazif View Post
    Ive faced a similar issue just before my car battery went completely flat! When was the last time the car battery was replaced?
    car Battery replaced two weeks back, the problem started before battery was replaced and its still after replacing the battery.

  6. #6
    Fresh Meat
    Join Date
    Jul 2017
    Ride
    BMW E60 545i
    Location
    UAE
    Posts
    6
    Status
    Offline
    Thanks (Received)
    1
    Likes (Received)
    0
    Dislikes (Received)
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Rep Power
    0

    Default

    Hi Guys,

    Finally fixed the issue, it was related to the corroded/oxidized contacts of the receiver. i cleaned the contacts and mounted back. Keys works like a charm. check the image of the receiver which i cleaned.
    inv_005825_01.jpg

  7. #7

    Wazif's Avatar
    Join Date
    May 2008
    Ride
    BMW E46 M3 BMW E92 M3 BMW F80 M3
    Location
    Dubai, UAE
    Posts
    4,821
    Status
    Offline
    Thanks (Received)
    111
    Likes (Received)
    262
    Dislikes (Received)
    1
    Mentioned
    55 Post(s)
    Tagged
    0 Thread(s)
    Rep Power
    25

    Default

    nice! thats a good catch..how did you diagnose it? Where is this part located?

    Current
    E92 M3 - Mineral White
    F80 M3 - SilverStone
    Past
    E36 318is
    E39 540i ///M sport
    VW CC
    E46 M3 - Frozen White

  8. #8
    Fresh Meat
    Join Date
    Jul 2017
    Ride
    BMW E60 545i
    Location
    UAE
    Posts
    6
    Status
    Offline
    Thanks (Received)
    1
    Likes (Received)
    0
    Dislikes (Received)
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Rep Power
    0

    Default

    Quote Originally Posted by Wazif View Post
    nice! thats a good catch..how did you diagnose it? Where is this part located?
    How did i catch it: As my keys and central locking was working fine and there were no errors registered in the system so i suspected something is wrong with signal receiver (Amplifier diversity antenna). i opened the Amplifier diversity antenna and found its metal strip touch contact with screen were rusted. i cleaned the circuit board and the metal strip touch contacts with electronic circuit cleaner (do not use cleaner like WD40 etc).

    Where it is located: check the attached image. You need to be very careful while removing it as the plastic panel which is covering it gets damaged.

    GREO_E60_65_0003.png

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

Sponsors